use strict;
my $str = '{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}';
my $regex = qr/("(?=-?\d*\.?\d+E[+-]?\d+)|(?<=E9)")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}