$re = '/("(?=-?\d*\.?\d+E[+-]?\d+)|(?<=E9)")/';
$str = '{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);