import Foundation
let pattern = #"("(?=-?\d*\.?\d+E[+-]?\d+)|(?<=E9)")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)