#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\<elem\skey=\"fqdn\"\>(?<fullDomainName>[^\<]+)<\/elem\>"
Local $sString = "<elem key="date">2016-11-27T13:01:38+01:00</elem>" & @CRLF & _
" <elem key="fqdn">XXXXXXXXX.mydomain.domain.com</elem>" & @CRLF & _
" <elem key="domain_dns">mydomain.domain.com</elem>" & @CRLF & _
" <elem key="forest_dns">domain.com</elem>" & @CRLF & _
" <elem key="workgroup">XXX\x00</elem>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")