// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\<elem\skey=\"fqdn\"\>(?<fullDomainName>[^\<]+)<\/elem\>"#).unwrap();
let string = "<elem key=\"date\">2016-11-27T13:01:38+01:00</elem>
<elem key=\"fqdn\">XXXXXXXXX.mydomain.domain.com</elem>
<elem key=\"domain_dns\">mydomain.domain.com</elem>
<elem key=\"forest_dns\">domain.com</elem>
<elem key=\"workgroup\">XXX\\x00</elem>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}