import re
regex = re.compile(r"\<elem\skey=\"fqdn\"\>(?<fullDomainName>[^\<]+)<\/elem\>")
test_str = ("<elem key=\"date\">2016-11-27T13:01:38+01:00</elem>\n"
" <elem key=\"fqdn\">XXXXXXXXX.mydomain.domain.com</elem>\n"
" <elem key=\"domain_dns\">mydomain.domain.com</elem>\n"
" <elem key=\"forest_dns\">domain.com</elem>\n"
" <elem key=\"workgroup\">XXX\\x00</elem>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")