import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<elem\\skey=\\\"fqdn\\\"\\>(?<fullDomainName>[^\\<]+)<\\/elem\\>";
final String string = "<elem key=\"date\">2016-11-27T13:01:38+01:00</elem>\n"
+ " <elem key=\"fqdn\">XXXXXXXXX.mydomain.domain.com</elem>\n"
+ " <elem key=\"domain_dns\">mydomain.domain.com</elem>\n"
+ " <elem key=\"forest_dns\">domain.com</elem>\n"
+ " <elem key=\"workgroup\">XXX\\x00</elem>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}