using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?_ExampleXML_(.*?)_[^_]+\.xml$";
string input = @"First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml
Second_ExampleXML_OnlyThisShouldBeName_202156789.xml
Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml
Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}