import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?_ExampleXML_(.*?)_[^_]+\\.xml$";
final String string = "First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml\n"
+ "Second_ExampleXML_OnlyThisShouldBeName_202156789.xml\n"
+ "Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml\n"
+ "Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}