use strict;
my $str = 'First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml
Second_ExampleXML_OnlyThisShouldBeName_202156789.xml
Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml
Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml';
my $regex = qr/^.*?_ExampleXML_(.*?)_[^_]+\.xml$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}