import re
regex = re.compile(r"^.*?_ExampleXML_(.*?)_[^_]+\.xml$", flags=re.MULTILINE)
test_str = ("First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml\n"
"Second_ExampleXML_OnlyThisShouldBeName_202156789.xml\n"
"Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml\n"
"Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")