using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<tz_utf>(?:\([^)]+\)|[^-]+)+)\s+-\s+(?<tz>[^:]+)\s+:\s+(?<fr>[^/]+)\s+/\s+(?<en>[^/]+)\s+/\s+(?<ar>\S+)\s+(?<tz_dec_utf>[ⴰ-⵿ -]+)\s+(?<tz_dec>.*)$";
string input = @"ⵜⴰⵙⵎⵙⵙⵉⵜ - tasmessit : Focalisée / Focus / QCÉÑe ⵜⴰⵙⵎⵙⵙⵉⵜ - ⵜⵙⵎⵙⵙⵉⵜ - ⵜⵉⵙⵎⵙⵙⵉⵜⵉⵠtasmssit - tsmssit - tismssitin
ⵜⴰⵙâµâ´°âµ¥âµ–ⵓⵕⵜ ( âµ-) - tasnaÇvurt (n-) : Etymologique / Etymological / »dÉKCG ⵠⵜⵙâµâ´°âµ¥âµ–ⵓⵕⵜ n tesnaÇvurt
ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - tasvunt tanadawt : Subordonnant / Subordinating (conjunction) / §HGQ ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - ⵜⵉⵙⵖⵡⴰⵠⵜⵉâµâ´°â´·â´°âµ¡âµ‰âµ tasvunt tanadawt - tisevwan tinadawin";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}