use strict;
my $str = 'ⵜⴰⵙⵎⵙⵙⵉⵜ - tasmessit : Focalisée / Focus / QCÉÑe ⵜⴰⵙⵎⵙⵙⵉⵜ - ⵜⵙⵎⵙⵙⵉⵜ - ⵜⵉⵙⵎⵙⵙⵉⵜⵉⵠtasmssit - tsmssit - tismssitin
ⵜⴰⵙâµâ´°âµ¥âµ–ⵓⵕⵜ ( âµ-) - tasnaÇvurt (n-) : Etymologique / Etymological / »dÉKCG ⵠⵜⵙâµâ´°âµ¥âµ–ⵓⵕⵜ n tesnaÇvurt
ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - tasvunt tanadawt : Subordonnant / Subordinating (conjunction) / §HGQ ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - ⵜⵉⵙⵖⵡⴰⵠⵜⵉâµâ´°â´·â´°âµ¡âµ‰âµ tasvunt tanadawt - tisevwan tinadawin';
my $regex = qr~^(?<tz_utf>(?:\([^)]+\)|[^-]+)+)\s+-\s+(?<tz>[^:]+)\s+:\s+(?<fr>[^/]+)\s+/\s+(?<en>[^/]+)\s+/\s+(?<ar>\S+)\s+(?<tz_dec_utf>[ⴰ-⵿ -]+)\s+(?<tz_dec>.*)$~imup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}