# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<tz_utf>(?:\([^)]+\)|[^-]+)+)\s+-\s+(?<tz>[^:]+)\s+:\s+(?<fr>[^/]+)\s+/\s+(?<en>[^/]+)\s+/\s+(?<ar>\S+)\s+(?<tz_dec_utf>[ⴰ-⵿ -]+)\s+(?<tz_dec>.*)$"
test_str = ("ⵜⴰⵙⵎⵙⵙⵉⵜ - tasmessit : Focalisée / Focus / QCÉÑe ⵜⴰⵙⵎⵙⵙⵉⵜ - ⵜⵙⵎⵙⵙⵉⵜ - ⵜⵉⵙⵎⵙⵙⵉⵜⵉⵠtasmssit - tsmssit - tismssitin\n"
"ⵜⴰⵙâµâ´°âµ¥âµ–ⵓⵕⵜ ( âµ-) - tasnaÇvurt (n-) : Etymologique / Etymological / »dÉKCG ⵠⵜⵙâµâ´°âµ¥âµ–ⵓⵕⵜ n tesnaÇvurt\n"
"ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - tasvunt tanadawt : Subordonnant / Subordinating (conjunction) / §HGQ ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - ⵜⵉⵙⵖⵡⴰⵠⵜⵉâµâ´°â´·â´°âµ¡âµ‰âµ tasvunt tanadawt - tisevwan tinadawin")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.