using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\d?(?::\d\d)?)\s+to\s+(\d\d?(?::\d\d)?)";
string input = @"8:30 to 17:00
8 to 18
09:00 to 14:30";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}