const regex = /(\d\d?(?::\d\d)?)\s+to\s+(\d\d?(?::\d\d)?)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d?(?::\\d\\d)?)\\s+to\\s+(\\d\\d?(?::\\d\\d)?)', 'gs')
const str = `8:30 to 17:00
8 to 18
09:00 to 14:30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}