re = /(\d\d?(?::\d\d)?)\s+to\s+(\d\d?(?::\d\d)?)/
str = '8:30 to 17:00
8 to 18
09:00 to 14:30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end