use strict;
my $str = '8:30 to 17:00
8 to 18
09:00 to 14:30';
my $regex = qr/(\d\d?(?::\d\d)?)\s+to\s+(\d\d?(?::\d\d)?)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}