import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(8)[\\s(-]{0,3}[0-9]{3}[\\s)-]{0,3}[0-9]{3}[\\s-]{0,3}[0-9]{2}[\\s-]{0,3}([0-9]{2})$";
final String string = "8-911-50-656-33";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}