re = /^(8)[\s(-]{0,3}[0-9]{3}[\s)-]{0,3}[0-9]{3}[\s-]{0,3}[0-9]{2}[\s-]{0,3}([0-9]{2})$/
str = '8-911-50-656-33'
# Print the match result
str.match(re) do |match|
puts match.to_s
end