import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(8)[\s(-]{0,3}[0-9]{3}[\s)-]{0,3}[0-9]{3}[\s-]{0,3}[0-9]{2}[\s-]{0,3}([0-9]{2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"8-911-50-656-33"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}