const regex = /^(8)[\s(-]{0,3}[0-9]{3}[\s)-]{0,3}[0-9]{3}[\s-]{0,3}[0-9]{2}[\s-]{0,3}([0-9]{2})$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(8)[\\s(-]{0,3}[0-9]{3}[\\s)-]{0,3}[0-9]{3}[\\s-]{0,3}[0-9]{2}[\\s-]{0,3}([0-9]{2})$', 'u')
const str = `8-911-50-656-33`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}