# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(https?:\/\/)?(www\.)?//img;t' <<< "google.com
www.google.com
http://google.com
http://www.google.com"