$re = '~^(https?://)?(www\.)?~im';
$str = 'google.com
www.google.com
http://google.com
http://www.google.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;