const regex = new RegExp('^(https?://)?(www\\.)?', 'img')
const str = `google.com
www.google.com
http://google.com
http://www.google.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);