use strict;
my $str = 'google.com
www.google.com
http://google.com
http://www.google.com';
my $regex = qr~^(https?://)?(www\.)?~imp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";