package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(https?://)?(www\.)?`)
var str = `google.com
www.google.com
http://google.com
http://www.google.com`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}