import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+[0-9]{2}\\s)?(?:\\([0-9]{3}\\)|[0-9]{3})\\s[0-9]{3}(-|\\s)[0-9]{2}\\1[0-9]{2}";
final String string = "+38 (093) 937-99-92\n"
+ "093 937 99 92\n"
+ "(093) 937 99 92";
final String subst = "\\1and\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}