const regex = new RegExp('^(?:\\+[0-9]{2}\\s)?(?:\\([0-9]{3}\\)|[0-9]{3})\\s[0-9]{3}(-|\\s)[0-9]{2}\\1[0-9]{2}', 'gmi')
const str = `+38 (093) 937-99-92
093 937 99 92
(093) 937 99 92`;
const subst = `\1and\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);