re = /^(?:\+[0-9]{2}\s)?(?:\([0-9]{3}\)|[0-9]{3})\s[0-9]{3}(-|\s)[0-9]{2}\1[0-9]{2}/mix
str = '+38 (093) 937-99-92
093 937 99 92
(093) 937 99 92'
subst = '\\1and\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result