import Foundation
let pattern = #"^(?:\+[0-9]{2}\s)?(?:\([0-9]{3}\)|[0-9]{3})\s[0-9]{3}(-|\s)[0-9]{2}\1[0-9]{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
+38 (093) 937-99-92
093 937 99 92
(093) 937 99 92
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1and\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)