use strict;
my $str = '+38 (093) 937-99-92
093 937 99 92
(093) 937 99 92';
my $regex = qr/^(?:\+[0-9]{2}\s)?(?:\([0-9]{3}\)|[0-9]{3})\s[0-9]{3}(-|\s)[0-9]{2}\1[0-9]{2}/mixp;
my $subst = '\\1and\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";