#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(((?:\<|\[)a href=\'|\")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)"
Local $sString = "[a href='http://vk.com/id9025145']ntcn[/a]" & @CRLF & _
"<a href='http://vk.com/id9025145'>ntcn</a>" & @CRLF & _
"http://vk.com/id9025145"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")