import re
regex = re.compile(r"(((?:\<|\[)a href=\'|\")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)", flags=re.IGNORECASE | re.DOTALL)
test_str = ("[a href='http://vk.com/id9025145']ntcn[/a]\n"
"<a href='http://vk.com/id9025145'>ntcn</a>\n"
"http://vk.com/id9025145")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")