import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((?:\\<|\\[)a href=\\'|\\\")?((?:http:\\/\\/)?((?:www\\.)?(?:[\\w\\d-_]*?\\.)+(?:\\w{2,4}))(?:\\/?)(?:[\\w\\d-_]+))((?:(?:\\'|\\\")(?:\\>|\\]))(?:[\\w\\d-_]+)(?:(?:\\<|\\[)\\/a(?:\\>|\\])))?)";
final String string = "[a href='http://vk.com/id9025145']ntcn[/a]\n"
+ "<a href='http://vk.com/id9025145'>ntcn</a>\n"
+ "http://vk.com/id9025145";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}