import Foundation
let pattern = #"(((?:\<|\[)a href=\'|\")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
[a href='http://vk.com/id9025145']ntcn[/a]
<a href='http://vk.com/id9025145'>ntcn</a>
http://vk.com/id9025145
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}