use strict;
my $str = '[a href=\'http://vk.com/id9025145\']ntcn[/a]
<a href=\'http://vk.com/id9025145\'>ntcn</a>
http://vk.com/id9025145';
my $regex = qr/(((?:\<|\[)a href=\'|\")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)/isp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}