using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+44\s?|\+44\s?0)7\d{3}\s?\d{6}|(00\s?44\s?|00\s?44\s?0)7\d{3}\s?\d{6}";
string input = @"+4407775800252
+447775800252
+44 07775 800252
+44 7775 800252
+44 07775 800252 999
+44 7775 800252 999
00 44 07775 800252
00 44 7775 800252
004407775800252 999
00447775800252 999
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}