import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+44\\s?|\\+44\\s?0)7\\d{3}\\s?\\d{6}|(00\\s?44\\s?|00\\s?44\\s?0)7\\d{3}\\s?\\d{6}";
final String string = "+4407775800252\n"
+ "+447775800252\n\n"
+ "+44 07775 800252\n"
+ "+44 7775 800252\n\n"
+ "+44 07775 800252 999\n"
+ "+44 7775 800252 999\n\n"
+ "00 44 07775 800252\n"
+ "00 44 7775 800252\n\n"
+ "004407775800252 999\n"
+ "00447775800252 999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}