import re
regex = re.compile(r"(\+44\s?|\+44\s?0)7\d{3}\s?\d{6}|(00\s?44\s?|00\s?44\s?0)7\d{3}\s?\d{6}", flags=re.MULTILINE)
test_str = ("+4407775800252\n"
"+447775800252\n\n"
"+44 07775 800252\n"
"+44 7775 800252\n\n"
"+44 07775 800252 999\n"
"+44 7775 800252 999\n\n"
"00 44 07775 800252\n"
"00 44 7775 800252\n\n"
"004407775800252 999\n"
"00447775800252 999\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")