$re = '/(\+44\s?|\+44\s?0)7\d{3}\s?\d{6}|(00\s?44\s?|00\s?44\s?0)7\d{3}\s?\d{6}/m';
$str = '+4407775800252
+447775800252
+44 07775 800252
+44 7775 800252
+44 07775 800252 999
+44 7775 800252 999
00 44 07775 800252
00 44 7775 800252
004407775800252 999
00447775800252 999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);