const regex = /(\+44\s?|\+44\s?0)7\d{3}\s?\d{6}|(00\s?44\s?|00\s?44\s?0)7\d{3}\s?\d{6}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+44\\s?|\\+44\\s?0)7\\d{3}\\s?\\d{6}|(00\\s?44\\s?|00\\s?44\\s?0)7\\d{3}\\s?\\d{6}', 'gm')
const str = `+4407775800252
+447775800252
+44 07775 800252
+44 7775 800252
+44 07775 800252 999
+44 7775 800252 999
00 44 07775 800252
00 44 7775 800252
004407775800252 999
00447775800252 999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}