package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?ix)
(\d+:\d\d)
\s+
.*?
\b
(
mon(?:d(?:ay?)?)
|tue(?:s(?:d(?:ay?)?)?)?
|wed(?:n(?:e(?:s(?:d(?:ay?)?)?)?)?)?
|thu(?:r(?:s(?:d(?:ay?)?)?)?)?
|fri(?:d(?:ay?)?)
|sat(?:u(?:r(?:d(?:a)?)?)?)?(?:y)?
|sun(?:d(?:ay?)?)
)
.*`)
var str = `0:18 on Tuesday's mini
1:43 Wednesday. dang!
2:01 this Sat 😎`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}