re = /(?ix)
(\d+:\d\d)
\s+
.*?
\b
(
mon(?:d(?:ay?)?)
|tue(?:s(?:d(?:ay?)?)?)?
|wed(?:n(?:e(?:s(?:d(?:ay?)?)?)?)?)?
|thu(?:r(?:s(?:d(?:ay?)?)?)?)?
|fri(?:d(?:ay?)?)
|sat(?:u(?:r(?:d(?:a)?)?)?)?(?:y)?
|sun(?:d(?:ay?)?)
)
.*/m
str = '0:18 on Tuesday\'s mini
1:43 Wednesday. dang!
2:01 this Sat 😎'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result