import Foundation
let pattern = #"""
(?ix)
(\d+:\d\d)
\s+
.*?
\b
(
mon(?:d(?:ay?)?)
|tue(?:s(?:d(?:ay?)?)?)?
|wed(?:n(?:e(?:s(?:d(?:ay?)?)?)?)?)?
|thu(?:r(?:s(?:d(?:ay?)?)?)?)?
|fri(?:d(?:ay?)?)
|sat(?:u(?:r(?:d(?:a)?)?)?)?(?:y)?
|sun(?:d(?:ay?)?)
)
.*
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0:18 on Tuesday's mini
1:43 Wednesday. dang!
2:01 this Sat 😎
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)