# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?ix)\n"
r"(\d+:\d\d)\n"
r"\s+\n"
r".*?\n"
r"\b\n"
r"(\n"
r" mon(?:d(?:ay?)?)\n"
r"|tue(?:s(?:d(?:ay?)?)?)?\n"
r"|wed(?:n(?:e(?:s(?:d(?:ay?)?)?)?)?)?\n"
r"|thu(?:r(?:s(?:d(?:ay?)?)?)?)?\n"
r"|fri(?:d(?:ay?)?)\n"
r"|sat(?:u(?:r(?:d(?:a)?)?)?)?(?:y)?\n"
r"|sun(?:d(?:ay?)?)\n"
r")\n"
r".*")
test_str = ("0:18 on Tuesday's mini\n"
"1:43 Wednesday. dang!\n"
"2:01 this Sat 😎")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.