# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*Out:)(0x[0-9a-f]{1,8}) In:0x[0-9a-f]{1,8}\.([0-9a-f]{1,8})./\2:\3/gm;t' <<< "2020-11:11:17.401 KEYWORD: Out:0xaaaf0000 In:0x80000000.1110ffff.
"