$re = '/(.*Out:)(0x[0-9a-f]{1,8}) In:0x[0-9a-f]{1,8}\.([0-9a-f]{1,8})./m';
$str = '2020-11:11:17.401 KEYWORD: Out:0xaaaf0000 In:0x80000000.1110ffff.
';
$subst = "\2:\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;