const regex = new RegExp('(.*Out:)(0x[0-9a-f]{1,8}) In:0x[0-9a-f]{1,8}\\.([0-9a-f]{1,8}).', 'gm')
const str = `2020-11:11:17.401 KEYWORD: Out:0xaaaf0000 In:0x80000000.1110ffff.
`;
const subst = `\2:\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);