use strict;
my $str = '2020-11:11:17.401 KEYWORD: Out:0xaaaf0000 In:0x80000000.1110ffff.
';
my $regex = qr/(.*Out:)(0x[0-9a-f]{1,8}) In:0x[0-9a-f]{1,8}\.([0-9a-f]{1,8})./mp;
my $subst = '\\2:\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";